myVCU Portal Outage

Incident
March 19, 7:46am EDT

myVCU Portal Outage

Status: closed
Start: March 19, 7:30am EDT
End: March 19, 7:46am EDT
Duration: 16 minutes
Affected Components:
Web Applications myVCU Portal
Update

March 19, 7:30am EDT

March 19, 7:30am EDT

We are currently experiencing an issue with the myVCU Portal. Users are reporting that content is not loading after login. Our team is investigating and working to resolve the problem.

Please contact the IT Support Center with any questions or concerns at 804-828-2227 or itsc@vcu.edu. 

Resolved

March 19, 7:46am EDT

March 19, 7:46am EDT

The issue affecting the myVCU Portal has been resolved. Content is now loading correctly after login. Thank you for your patience.

Please contact the IT Support Center with any questions or concerns at 804-828-2227 or itsc@vcu.edu.