Email Delivery Delay for mail from @vcuhealth.org addresses

Incident
July 24, 10:18am EDT

Email Delivery Delay for mail from @vcuhealth.org addresses

Status: closed
Start: July 20, 11:10am EDT
End: July 24, 10:18am EDT
Duration: 3 days 23 hours 8 minutes
Affected Components:
E-mail & Collaboration Google Workspace Office365 ListPlex Maestro Listserv Zixmail Gmail
Update

July 20, 11:10am EDT

July 20, 11:10am EDT

Customers are experiencing delays in receiving email to their VCU email accounts from @vcuhealth.org addresses. We have identified delays in email delivery, and have opened a support request with the vendor, Zixmail.

Please contact the IT Support Center with any questions or concerns at 804-828-2227 or itsc@vcu.edu. 

Resolved

July 24, 10:18am EDT

July 24, 10:18am EDT

The email issue related to receiving email from @vcuhealth.org addresses has been resolved as ZIX mail queues have cleared. The vendor has also indicated they will implement measures to prevent this from happening in the future.

Please contact the IT Support Center with any questions or concerns at 804-828-2227 or itsc@vcu.edu.