Email Delivery Delay

Informational
September 29, 5:04pm EDT

Email Delivery Delay

Status: closed
Date: September 29, 2:39pm EDT
End: September 29, 5:04pm EDT
Duration: 2 hours 25 minutes
Affected Components:
E-mail & Collaboration Google Workspace Gmail Google Calendar Google Chat Google Drive Google Groups Google Meet Classroom Google Forms
Update

September 29, 2:39pm EDT

September 29, 2:39pm EDT

Customers may experience delays in receiving email to their VCU email account. The delay is related to a global issue with our Cisco email security appliances which has been identified and resolved. Queued email is being delivered.

Please contact the IT Support Center with any questions or concerns at 804-828-2227 or itsc@vcu.edu. 

Resolved

September 29, 5:04pm EDT

September 29, 5:04pm EDT

The email issue related to receiving email to VCU email accounts has been resolved.

Please contact the IT Support Center with any questions or concerns at 804-828-2227 or itsc@vcu.edu.