Email Delivery Delay

Incident
October 03, 9:26pm EDT

Email Delivery Delay

Status: closed
Start: October 02, 3:15pm EDT
End: October 03, 9:26pm EDT
Duration: 1 day 6 hours 11 minutes
Affected Components:
E-mail & Collaboration Google Workspace ListPlex Maestro Listserv Zixmail Gmail Google Calendar Google Chat Google Drive Google Groups Google Meet Classroom Google Forms
Update

October 02, 3:15pm EDT

October 02, 3:15pm EDT

Customers are experiencing delays in sending and receiving email to their VCU email account. We have identified delays in email delivery, and are actively investigating. 

Please contact the IT Support Center with any questions or concerns at 804-828-2227 or itsc@vcu.edu. 

Monitoring

October 02, 4:07pm EDT

October 02, 4:07pm EDT

A majority of emails are now being delivered as delays are clearing.

We are continuing to monitor to ensure emails continue to be delivered without issue.

For questions or issues, please contact the IT Support Center at 804-828-2227.

Resolved

October 03, 9:26pm EDT

October 03, 9:26pm EDT

The email issue related to sending and receiving email to VCU email accounts has been resolved.

Please contact the IT Support Center with any questions or concerns at 804-828-2227 or itsc@vcu.edu.