The IT Support Call Center is unreachable by phone

Incident
October 03, 3:19pm EDT

The IT Support Call Center is unreachable by phone

Status: closed
Start: October 03, 3:00pm EDT
End: October 03, 3:19pm EDT
Duration: 19 minutes
Affected Components:
IT Support & Campus Resources IT Support Center Services
Update

October 03, 3:00pm EDT

October 03, 3:00pm EDT

Due to ongoing network issues, the ITSC call center is unreachable by phone. You can still reach us at itsc@vcu.edu and we will reply as quickly as possible. Our front counter also remains available.

We will update you as soon as it is resolved.

Update

October 03, 3:10pm EDT

October 03, 3:10pm EDT

The call center is slowly coming back online. Please be patient as we are experiencing higher call volume.

Resolved

October 03, 3:19pm EDT

October 03, 3:19pm EDT

Our phones are fully online, and the call center is now easily reachable. Thanks for bearing with us!

Please contact the IT Support Center with any questions or concerns at 804-828-2227 or itsc@vcu.edu.