Scheduled Maintenance for Degree Works Production

Maintenance
June 29, 5:00am EDT

Scheduled Maintenance for Degree Works Production

Status: closed
Start: June 28, 8:30pm EDT
End: June 29, 5:00am EDT
Duration: 8 hours 30 minutes
Affected Components:
University Applications Degree Works
Update

June 28, 8:30pm EDT

June 28, 8:30pm EDT

VCU Technology Services will be performing routine maintenance beginning on 06/28/2024 starting at 8:30 PM EDT.

You may not be able to access Degree Works Production for a short period of time, but we’ll have things back up and running as soon as possible to minimize disruptions.

Please contact the IT Support Center with any questions or concerns at 804-828-2227 or itsc@vcu.edu. 

Resolved

June 29, 5:00am EDT

June 29, 5:00am EDT

Scheduled maintenance for Degree Works Production is complete. 

Please contact the IT Support Center with any questions or concerns at 804-828-2227 or itsc@vcu.edu.