Emails are not being delivered to Google Groups.

Incident
July 17, 1:50pm EDT

Emails are not being delivered to Google Groups.

Status: closed
Start: July 17, 9:16am EDT
End: July 17, 1:50pm EDT
Duration: 4 hours 34 minutes
Affected Components:
E-mail & Collaboration Google Workspace Google Groups
Update

July 17, 9:16am EDT

July 17, 9:16am EDT

When sending an email to a Google Group, customers will immediately receive a bounce (failed delivery) email and the message is not delivered to the Group.

We are currently investigating this issue.

Please contact the IT Support Center at 804-828-2227 or itsc@vcu.edu with any questions or concerns.

Resolved

July 17, 1:50pm EDT

July 17, 1:50pm EDT

The email issue related to sending emails to Google Groups has been identified and resolved. Thank you for your patience. 

Please contact the IT Support Center at 804-828-2227 or itsc@vcu.edu with any questions or concerns.