Scam Warning: Global Crowdstrike Outage

Informational
August 27, 2:47pm EDT

Scam Warning: Global Crowdstrike Outage

Status: closed
Date: July 19, 12:20pm EDT
End: August 27, 2:47pm EDT
Duration: 39 days 2 hours 27 minutes
Affected Components:
Accounts, Access & Security Data Security Phishing Scams
Update

July 19, 12:20pm EDT

July 19, 12:20pm EDT

Please be advised that there are active scammers taking advantage of the Global Crowdstrike Outage calling and trying to "help" in remediating the issue for user's Windows computers. Please be advised that these are scammers trying to gain access to machines. Please do not allow anyone that you do not know access to your device. Reach out to the IT Support Center with any questions or concerns at 804-828-2227.

Resolved

August 27, 2:47pm EDT

August 27, 2:47pm EDT

This warning is being resolved due to the length of time since the Crowdstrike incident. You should always be wary of any unsolicited offer of computer support. Do not allow anyone you do not know access to your devices. Contact the IT Support Center with any questions or concerns at 804-828-2227.