Email Delivery Delay

Incident
July 19, 2:56pm EDT

Email Delivery Delay

Status: closed
Start: July 19, 1:36pm EDT
End: July 19, 2:56pm EDT
Duration: 1 hour 20 minutes
Affected Components:
E-mail & Collaboration Google Workspace ListPlex Maestro Listserv Zixmail Gmail Google Calendar Google Chat Google Drive Google Groups Google Meet Classroom Google Forms
Update

July 19, 1:36pm EDT

July 19, 1:36pm EDT

Customers are experiencing delays in sending and receiving email to their VCU email account. We have identified delays in email delivery, and are actively investigating. 

Please contact the IT Support Center with any questions or concerns at 804-828-2227 or itsc@vcu.edu. 

Resolved

July 19, 2:56pm EDT

July 19, 2:56pm EDT

The email issue related to sending and receiving email to VCU email accounts has been resolved.

Please contact the IT Support Center with any questions or concerns at 804-828-2227 or itsc@vcu.edu.