Issue with Kaltura videos and new MacOS Sequoia
Incident
September 27, 10:16am EDT
Issue with Kaltura videos and new MacOS Sequoia
Status: in progress
Start:
September 27, 10:16am EDT
Affected Components:
Teaching & Learning
Kaltura
Update
September 27, 10:16am EDT
September 27, 10:16am EDT
Apple's newest OS update Sequoia, has removed the crucial cookie setting from both the system and browser settings the browser in question only being Safari.
The effects this is having means that Safari users will see a "3rd party cookies are blocking content" error anytime they launch Kaltura media through Canvas. This is not affecting other browsers at this time. Kaltura is aware of the issue and is working on implementing a fix but do not have an ETA on resolution.
Safari: The crucial cookies setting has been removed system-wide on iOS and iPadOS, as well as in the browser on macOS. This is impacting functionality across all Apple devices.
Chrome: The cookie setting is still available on macOS but has been removed for iPad and iPhone. As a result, Chrome only works as expected on Mac.
Current workaround: Have users view the videos on Chrome or Firefox for Mac.
(Note: This is not affecting windows users.)