Scheduled Maintenance for Degree Works Production

Maintenance
January 26, 4:30am EST

Scheduled Maintenance for Degree Works Production

Status: closed
Start: January 25, 8:30pm EST
End: January 26, 4:30am EST
Duration: 8 hours
Affected Components:
University Applications Degree Works
Update

January 25, 8:30pm EST

January 25, 8:30pm EST

VCU Technology Services will be performing routine maintenance beginning on 01/25/2025 starting at 8:30PM.

You may not be able to access Degree Works Production applications for a short period of time, but we’ll have things back up and running as soon as possible to minimize disruptions.

Please contact the IT Support Center with any questions or concerns at 804-828-2227 or itsc@vcu.edu. 

Resolved

January 26, 4:30am EST

January 26, 4:30am EST

Scheduled maintenance for Degree Works Production is complete. 

Please contact the IT Support Center with any questions or concerns at 804-828-2227 or itsc@vcu.edu.