Scheduled Maintenance for RamsCentral
Maintenance
in progress (4 days 4 hours 14 minutes)
January 31, 11:30pm EST
Scheduled Maintenance for RamsCentral
Status: in progress
Start:
January 31, 11:30pm EST
Affected Components:
IT Support & Campus Resources
HR Support Portal (RamsCentral)
IT Support Portal (RamsCentral)
Update
January 31, 11:30pm EST
January 31, 11:30pm EST
VCU Technology Services will be performing routine maintenance beginning on January 31st starting at 11:30
You may not be able to access RamsCentral for a short period of time, but we’ll have things back up and running as soon as possible to minimize disruptions.
Please contact the IT Support Center with any questions or concerns at 804-828-2227 or itsc@vcu.edu.