Scheduled Maintenance for Listplex Maestro

Maintenance
May 13, 4:01pm EDT

Scheduled Maintenance for Listplex Maestro

Status: closed
Start: May 13, 11:00am EDT
End: May 13, 4:01pm EDT
Duration: 5 hours 1 minute
Affected Components:
E-mail & Collaboration ListPlex Maestro
Update

May 13, 11:00am EDT

May 13, 11:00am EDT

L-Soft, the vendor for Listplex Maestro, will be performing an upgrade for Listplex Maestro starting May 13, 2025 at 11 AM until 4 PM.

Maestro will be unavailable during the maintenance. A list of the features in this new version can be found linked here.

Please contact the IT Support Center with any questions or concerns at 804-828-2227 or itsc@vcu.edu. 

Resolved

May 13, 4:01pm EDT

May 13, 4:01pm EDT

Scheduled maintenance for Maestro is completed. 

Please contact the IT Support Center with any questions or concerns at 804-828-2227 or itsc@vcu.edu.