Scheduled Maintenance for VCU Reporting Center

Maintenance
May 19, 7:00pm EDT

Scheduled Maintenance for VCU Reporting Center

Status: closed
Start: May 19, 5:00pm EDT
End: May 19, 7:00pm EDT
Duration: 2 hours
Affected Components:
Data, Research & Reporting VCU Reporting Center
Update

May 19, 5:00pm EDT

May 19, 5:00pm EDT

VCU Technology Services will be performing routine maintenance beginning on 5/19/2025 starting at 5:00 PM EST.

You may not be able to access the VCU Reporting Center for a short period of time, but we’ll have things back up and running as soon as possible to minimize disruptions.

Please contact the IT Support Center with any questions or concerns at 804-828-2227 or itsc@vcu.edu. 

Resolved

May 19, 7:00pm EDT

May 19, 7:00pm EDT

Scheduled maintenance for the VCU Reporting Center is complete. 

Please contact the IT Support Center with any questions or concerns at 804-828-2227 or itsc@vcu.edu.