Email Delivery Issue to vcuhealth.org accounts

Informational
June 20, 11:43am EDT

Email Delivery Issue to vcuhealth.org accounts

Status: closed
Date: June 17, 1:20pm EDT
End: June 20, 11:43am EDT
Duration: 2 days 22 hours 23 minutes
Affected Components:
E-mail & Collaboration Google Workspace Zixmail Gmail Google Calendar Google Chat Google Drive Google Groups Google Meet Classroom Google Forms
Update

June 17, 1:20pm EDT

June 17, 1:20pm EDT

Some customers may experience email delivery failures when sending emails to accounts ending in vcuhealth.org accounts.

VCU Health is aware of the issue and is actively working with Zixmail to resolve the issue.

Please contact the IT Support Center with any questions or concerns at 804-828-2227 or itsc@vcu.edu. 

Resolved

June 20, 11:43am EDT

June 20, 11:43am EDT

The email issue related to sending emails to VCUHS email accounts has been resolved.

Please contact the IT Support Center with any questions or concerns at 804-828-2227 or itsc@vcu.edu.